The orders page on the Control4 dealer portal is unavailable
Incident Report for Snap One
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 16:30 EDT
Investigating
We are currently investigating this issue and hope to resolve it quickly. Thank you for your patience.
Posted Sep 20, 2022 - 12:49 EDT
This incident affected: Partner Services Health (Website: dealer.control4.com).