As of 6:30PM ET the situation was fully resolved. We will dive deeper into root causes and provide you with details on how we will improve our services. Thank you for your patience and understanding.
Your Snap One Engineering team
Posted Jun 05, 2025 - 18:32 EDT
Monitoring
The fix has been applied and remote connections are returning to normal. You may experience slight impacts to performance as systems fully ramp up and stabilize - however we are already seeing significant improvement and more consistency in performance metrics. More details to follow.
Thanks, Your Snap One Engineering team
Posted Jun 05, 2025 - 17:58 EDT
Update
We want to apologize for the disruption this issue is causing. We know how critical Composer Pro, Intercom Anywhere, and other Control4 services are to your business and your customers — and we take that responsibility seriously.
Restoring full functionality is our absolute top priority. Our engineering team is working around the clock and has already made significant progress. We will continue to provide regular updates until all issues are fully resolved. Thank you again for your patience and understanding.
Posted Jun 05, 2025 - 13:48 EDT
Identified
We are aware of continued degraded performance and/or intermittent availability of remote configuration through Composer Pro. We are actively working towards a solution. More details will follow.
Thanks, Your Snap One Engineering team
Posted Jun 05, 2025 - 10:10 EDT
Monitoring
Additional changes have been applied to stabilize services which support remote access in Composer Pro. You may experience slight impacts to performance as systems fully ramp up and stabilize. More details to follow.
Thanks, Your Snap One Engineering team
Posted Jun 04, 2025 - 13:48 EDT
This incident affected: Control4 Health (Service: Control4 Composer Pro).