Snap One DDNS issue identified, investigation underway.
Incident Report for Snap One
Resolved
The Snap One DDNS service is recovered. We will dive deeper into root causes and how we will improve our services. Thank you for your patience and understanding.

Your Snap One Engineering team
Posted May 31, 2023 - 21:48 EDT
Investigating
We have identified an issue with Snap One DDNS. We are aware of and actively investigating solutions and impact. More details to follow. Thanks, Your Snap One Engineering team
Posted May 31, 2023 - 19:55 EDT
This incident affected: End-Customer Services Health (Service: Snap One DDNS [Luma, Wattbox, and other products]).