OvrC - Issue Fix Applied. Returning to normal.

Incident Report for Snap One

Resolved

As of 11:13am ET the situation was fully resolved. We will dive deeper into root causes and provide you with details on how we will improve our services. Thank you for your patience and understanding.

Your Snap One Engineering team
Posted Mar 17, 2026 - 11:34 EDT

Monitoring

An issue impacting the performance of OvrC is being monitored. The root cause has been identified and the fix has been applied. OvrC is returning to normal with Partners able to use services. You may experience slight impacts to performance as systems fully ramp up and stabilize. More details to follow.

Thanks, Your Snap One Engineering team
Posted Mar 17, 2026 - 11:11 EDT
This incident affected: OvrC Health (Mobile App: OvrC, Mobile App: OvrC Connect, Service: OvrC Device Communication & Configuration, Service: OvrC Firmware Updates, Service: OvrC Login, Service: OvrC Notifications, Service: OvrC Public APIs, Service: OvrC Web Connect, Service: OvrC Speed Test, Service: OvrC MFA - SMS, Service: OvrC Account Creation).