Service Impact for Order Placement
Incident Report for Snap One
Resolved
Issue has been fully resolved.
Posted Jul 22, 2024 - 15:26 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 13:58 EDT
Identified
We're experiencing technical difficulties due to global system outages. Order fulfillment may be delayed due to these issues, but we are working to resolve them as soon as possible. We apologize for the inconvenience.
Posted Jul 19, 2024 - 13:50 EDT
Investigating
We're experiencing technical difficulties with online order placement. Please use the "Need Assistance" link under the Checkout button to place your order. We apologize for the inconvenience.
Posted Jul 19, 2024 - 06:45 EDT
This incident affected: SnapOne Websites Health (Website: snapav.com, Website: dealer.control4.com, Website: dealer.triadspeakers.com).