Luma View Application not working for some users
Incident Report for Snap One
Resolved
All devices show successful connections, as DNS global replication was completed overnight. If any issues persist, please contact support for assistance.

Thank you for your patience during this transition. We appreciate your understanding and support.
Posted Oct 04, 2024 - 10:11 EDT
Identified
Following the fix completed earlier today, we have reports of impacts for some users of the Luma View Application. If you’re still experiencing issues, please try rebooting your device (e.g., phone). We’re continuing to investigate and will provide further updates.

iOS users can also try enabling Private Relay by going to Settings > iCloud and turning on Private Relay (iCloud+ required).

We apologize for the inconvenience and appreciate your patience.
Thanks, Your Snap One Engineering team
Posted Oct 03, 2024 - 22:03 EDT
This incident affected: Luma Service Health (Mobile App: Luma View).