Control4 app - media events not available through history

Incident Report for Snap One

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2026 - 13:58 EDT

Identified

We have identified a fix, new events should be showing properly, older events may still be unavailable for a period while our servers update
Posted Apr 04, 2026 - 13:57 EDT

Investigating

We are aware of an issue affecting camera event media in the Control4 app. When accessing recorded camera events through the History experience, users may see a message stating "Media for this event is processing and will be available soon." Live camera streams are not affected by this issue.
Our engineering team has identified the area of impact and is actively working toward a resolution. More details will follow.
Thanks,
Your Snap One Engineering team
Posted Apr 04, 2026 - 13:29 EDT