Order processing delay for Asia-Pacific (APAC) warehouse
Incident Report for Snap One
Resolved
This incident has been resolved.
Posted May 19, 2023 - 15:59 EDT
Monitoring
We've resolved the incident and will continue to monitor. You can check your order status online. We apologize for any inconvenience this may have caused you.
Posted May 18, 2023 - 12:44 EDT
Identified
We've identified the problem, and our team is working on a resolution. At this time, there is no confirmed ETA for resolution.
Posted May 17, 2023 - 19:07 EDT
Investigating
As of 17 May 2023, orders are taking longer to process than usual due to a system outage impacting our Australia warehouse. Additionally, partners in the APAC region may have difficulty accessing Orders, Balance, and Online RMA under Account. Our team is actively investigating the incident and will update you with more details as we have them.

At Snap One, we're committed to providing the best possible service and are working tirelessly to resolve this incident. Check out our status page for the most up-to-date information: https://status.snapone.com/
Posted May 17, 2023 - 18:22 EDT
This incident affected: Partner Services Health (Website: dealer.control4.com).