Apple TV tvOS18 Control
Incident Report for Snap One
Update
Apple has identified the root cause of the issue affecting IP control on Apple TVs running tvOS 18. They are currently testing a potential fix on their side to ensure it resolves the problem. We are now awaiting further information from Apple regarding how and when the fix will be rolled out, once it has been verified.

We will continue to work closely with Apple and provide additional updates as soon as we have them.

Thank you for your ongoing patience and support.
Posted Oct 14, 2024 - 10:02 EDT
Update
Since successfully replicating this issue using Apple’s reference software, we are pleased to report that Apple has replicated the issue within its own environment, independent of the Control4 ecosystem. They are currently investigating the code to pinpoint the specific cause. At this stage, we await further insights from Apple regarding the root cause and the steps necessary for a resolution.

We will continue collaborating closely with Apple and provide updates as we learn more.

Thank you for your patience and ongoing support.
Posted Oct 08, 2024 - 12:31 EDT
Update
We have replicated the issue using Apple's reference software outside of the Control4 environment and have brought it to Apple's attention. We're collaborating closely with their team to identify the root cause and work toward a resolution. This remains a top priority for us, and we will continue to push forward with Apple to ensure a timely fix.
Posted Oct 03, 2024 - 12:20 EDT
Update
We continue to work closely with Apple regarding the issue affecting IP control on Apple TVs running tvOS 18. Apple has been responsive and is actively assisting us as we work through identifying the root cause of the problem.

While we are making progress in narrowing down potential causes, we still have not identified the specific root cause, and therefore do not yet have a fix. Once the root cause is determined, we will have a clearer understanding of what a permanent fix would entail and the timeline for its implementation.

As a reminder, if you or your customer encounter this issue, the best workaround is to reboot the Apple TV or the system, which may temporarily restore IP control. However, this is not a permanent solution, and we still recommend avoiding updating to tvOS 18 where possible.

We sincerely appreciate your patience and understanding during this ongoing process. We will provide more updates as we have additional information.

Thank you for your ongoing support.
Posted Sep 30, 2024 - 17:17 EDT
Update
We’d like to provide an update regarding the issue affecting IP control on Apple TVs running tvOS18. While we have not yet identified the root cause, we are actively investigating and collaborating closely with Apple, who is assisting us as we work through the issue.

This issue appears to be more widespread and is not limited to Control4 projects. Apple is aware and is working with us to help address the problem. Rest assured that this remains a top priority, and we are committed to finding a solution as quickly as possible. We will continue to share any meaningful progress as soon as it becomes available.

As a reminder, if you or your customer encounter this issue, the best workaround continues to be to reboot the Apple TV, which may temporarily restore IP control. Please note, however, that this is not a permanent fix, but it typically works as long as there are no further changes to the project (including system reboots). The best way to avoid this issue is still to avoid updating Apple TVs to tvOS18.

We sincerely appreciate your continued patience and understanding. We will keep you updated as we learn more and work toward a resolution.

Thank you for your ongoing support.
Posted Sep 24, 2024 - 19:01 EDT
Investigating
We are currently investigating an issue where IP control is lost on Apple TVs that have been updated to tvOS18, which became publicly available earlier this week. While rebooting the Apple TV or the system temporarily restores IP control, this appears to be only a short-term solution.

Previously, we significantly improved reliability with the Apple Bridge by closely monitoring the connection and automatically resetting it when it became unresponsive. However, with the latest tvOS release, this solution no longer seems effective.

We have submitted a bug report to Apple and are actively working on a long-term fix for this issue. In the meantime, we recommend that all partners and customers avoid upgrading to tvOS18. If you have already updated and are experiencing this issue, the current workaround is to reboot the Apple TV or system, though we acknowledge this is not a permanent resolution.

We understand how crucial this integration is to many systems, and we are treating this issue with the highest priority. We will provide further updates as they become available.

Thank you for your patience and understanding.
Posted Sep 19, 2024 - 17:13 EDT
This incident affects: Control4 Health (Service: Control4 Drivers).