Roku interoperability issue with Control4 identified. Investigation underway.
Incident Report for Snap One
Resolved
Roku has rolled out a fix and we have verified the issue has been resolved.
Posted Apr 15, 2024 - 16:17 EDT
Update
Roku Fix is Rolling Out:
Our Engineering Team has been working directly with Roku to resolve this issue. With this engagement, Roku has identified the cause and has been rolling out a solution since last evening. It should be complete by the end of the day today, April 5th.
The fix to restore service will be automatic—neither you nor your customers will need to take action. We are monitoring the rollout of the fix to confirm that the issue has been fully resolved.
Posted Apr 05, 2024 - 14:28 EDT
Monitoring
We have reported cases of this issue, but it does seem sporadic, with some systems experiencing it while others are still operating as normal. We have been coordinating with the Roku team since Monday. Roku recognizes the issue and understands the root cause. This problem appears to extend beyond Control4. The Roku team is expecting to fix the ECP functionality by next week.
Posted Apr 03, 2024 - 13:32 EDT
Identified
Numerous cases have been reported in the last few days of the loss of control of Roku devices through the Control4 system. There have not been any changes to the Roku driver recently and we currently leverage the published APIs by Roku, so we believe this is tied to a recent software update deployed by Roku. A Roku developer forum thread is also pointing to the same issue here. Our teams are looking into the impact details and contacting our contacts at Roku to find a solution as soon as possible. We'll provide an update as soon as we have more information.


Snap One Engineering
Posted Apr 01, 2024 - 15:27 EDT
This incident affected: End-Customer Services Health (Service: Control4 APIs).