Paytrace is experiencing issues and may impact some Snap One customers
Incident Report for Snap One
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 13:40 EDT
Monitoring
We are investigating an issue some Snap One partners might be experiencing related to our third-party payment system, Paytrace. We are working with Paytrace and monitoring the situation to resolve this as soon as possible for our partners.
Posted Jun 28, 2022 - 11:55 EDT
This incident affected: Third Party Dependencies Health (e.g., Amazon, Akamai, The Weather Channel, etc.) (Paytrace).