The issue with the Luma View application is fully resolved. We will dive deeper into root causes and provide you with details on how we will improve our services. Thank you for your patience and understanding.
Your Snap One Engineering team
Posted Jul 11, 2025 - 16:58 EDT
Monitoring
The issue affecting Luma View has been resolved. Our team will continue to closely monitor the system to ensure everything remains stable. We appreciate your patience and understanding during this time. If you experience any further issues, please don’t hesitate to contact our support team. Thank you.
Thanks, Your Snap One Engineering team
Posted Jul 11, 2025 - 15:17 EDT
Investigating
We are currently experiencing an issue with Luma View mobile app following today’s server update, which may affect its proper functioning for some users. Our team is actively investigating and working to resolve this as quickly as possible. We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding. We will provide an update as soon as the service is fully restored.
Thanks, Your Snap One Engineering team
Posted Jul 10, 2025 - 16:53 EDT
This incident affected: Luma Service Health (Mobile App: Luma View).