We have identified a problem with text message 2FA on OvrC

Incident Report for Snap One

Resolved

Service degradation has been fully resolved. We will dive deeper into root causes and use findings to continue to improve our services. Thank you for your patience and understanding.

Your Snap One Engineering team
Posted Apr 11, 2025 - 11:01 EDT

Identified

We are aware of the impacts on text message 2FA for OvrC and are actively engaged in determining the cause. More details will follow.

Thanks, Your Snap One Engineering team
Posted Apr 10, 2025 - 01:37 EDT
This incident affected: OvrC Health (Service: OvrC Login).