We have identified a problem with OvrC email deliveries

Incident Report for Snap One

Resolved

As of 10:20 PM ET, we consider the issue resolved. We will investigate the problem with our partner that led to this issue and continue to work to improve our services. Thank you for your patience and understanding.

Your Snap One Engineering team
Posted Apr 23, 2025 - 22:27 EDT

Monitoring

Update - Our third-party provider has provided the following update: "We have mitigated the issues affecting email sending and have also re-enabled our Bounce Suppressions list. Email traffic is now working 100% with all checks."

Emails should be flowing normally. We will continue to monitor the situation until the vendor closes the incident. More details to follow.

Thanks, Your Snap One Engineering team
Posted Apr 23, 2025 - 21:30 EDT

Identified

We are currently experiencing an issue with our third-party service provider responsible for OvrC email delivery. You may notice intermittent deliveries while they continue to work to resolve the issue. We will continue to monitor the situation, more details will follow.

Thanks, Your Snap One Engineering team
Posted Apr 23, 2025 - 18:53 EDT
This incident affected: OvrC Health (Service: OvrC Notifications).