SnapAV.com log in issue

Incident Report for Snap One

Resolved

We have resolved the log in incident and are continuing to monitor snapav.com performance. We apologize for any inconvenience this may have caused you.
Posted Mar 17, 2025 - 21:22 EDT

Investigating

We are aware that some customers are having difficulty logging into snapav.com. However, those who are already logged in can use the website without issues. Our team is currently investigating this problem and will provide updates as more information becomes available.
Posted Mar 17, 2025 - 18:10 EDT
This incident affected: SnapOne Websites Health (Website: snapav.com).