We have identified a problem with OvrC service

Incident Report for Snap One

Resolved

As of 3:30pm ET all of our services have fully recovered. Service impacts were caused by service failures by third-party service provider AWS. While we have observed service improvements implemented by AWS, additional information on the outage is available here:
Visit AWS Status Page

Thank you for your patience and understanding.
Posted Oct 20, 2025 - 15:38 EDT

Monitoring

A fix has been applied by our service provider and we are seeing systems beginning to recover. You may continue to experience impacts to performance and functionality as systems fully ramp up and stabilize. More details to follow.

Thanks, Your Snap One Engineering team
Posted Oct 20, 2025 - 13:46 EDT

Update

The latest update from our cloud providers indicates that they continue to work to resolve network, lambda, and server enviornment, we are actively engaged and will update as we make progress.
Posted Oct 20, 2025 - 13:21 EDT

Update

The latest update from our cloud providers indicates that they continue to work to resolve network and other issues, we are actively engaged and will update as we make progress.
Posted Oct 20, 2025 - 11:44 EDT

Update

We are seeing additional impacts across services due to our cloud service provider
Posted Oct 20, 2025 - 10:11 EDT

Identified

We are aware of the impacts on multiple services due to ongoing issues with our cloud provider. More details will follow.

Thanks, Your Snap One Engineering team
Posted Oct 20, 2025 - 10:01 EDT
This incident affected: Control4 Health (Mobile App: Control4 Intercom Anywhere Android, Mobile App: Control4 Intercom Anywhere iOS, Mobile App: Control4 OS 2.x Android, Mobile App: Control4 OS 3.x Android, Mobile App: Control4 OS 2.x iOS, Mobile App: Control4 OS 3.x iOS, Service: Control4 Alexa, Service: Control4 Google Assistant, Service: Control4 Intercom Anywhere), OvrC Health (Mobile App: OvrC, Mobile App: OvrC Connect, Service: OvrC Device Communication & Configuration, Service: OvrC Firmware Updates, Service: OvrC Login, Service: OvrC Notifications, Service: OvrC Public APIs, Service: OvrC Web Connect, Service: OvrC Speed Test), and Third Party Dependencies Health (e.g., Amazon, Akamai, The Weather Channel, etc.) (Amazon Web Services).