Snap One Partner Portal (snapav.com) and Dealer Portal (dealer.control4.com) - Issue Identified. Investigation underway.
Incident Report for Snap One
Resolved
The issues impacting snapav.com and dealer portal have now been resolved. Please notify us, if you experience any continued issues. Thank you!
Posted Dec 06, 2023 - 16:06 EST
Investigating
This issue is applicable to the Snap One Partner Portal (snapav.com) and Control4 Dealer Portals (dealer.control4.com and deal-emea.control4.com). We're currently experiencing a technical issue impacting speed of logging in, placing orders, using the Tech Community, and viewing the status of your returns. This issue also affects our Support team.
Our team is actively working on a resolution, and we apologize for the inconvenience.
Posted Dec 06, 2023 - 09:33 EST
This incident affected: SnapOne Partner Portal Health (Website: snapav.com) and Partner Services Health (Website: dealer.control4.com, Website: dealer-emea.control4.com).