We have identified a problem with text message 2FA on OvrC

Incident Report for Snap One

Resolved

As of 7:50 PM ET, we consider the issue resolved. We will investigate the problem with our partner that led to this issue and continue to work to improve our services. Thank you for your patience and understanding.

Your Snap One Engineering team
Posted Jun 25, 2025 - 19:57 EDT

Identified

We are aware of the impacts on text message 2FA for OvrC and are actively engaged in determining the cause. More details will follow.

Thanks, Your Snap One Engineering team
Posted Jun 25, 2025 - 14:22 EDT
This incident affected: OvrC Health (Service: OvrC Login).