Order processing delay
Incident Report for Snap One
Resolved
We’ve resolved the incident and will continue to monitor.
Posted Feb 24, 2023 - 22:33 EST
Identified
We've identified the problem, and our team is working on a resolution. At this time, there is no confirmed ETA for resolution.
Posted Feb 24, 2023 - 15:34 EST
Update
We are continuing to investigate this issue.
Posted Feb 24, 2023 - 10:49 EST
Investigating
As of 24-Feb-2023, orders are taking longer to process than usual due to a system outage. Additionally, partners may have difficulty accessing Orders, Balance, and Online RMA under Account. Our team is actively investigating the incident and will update you with more details as we have them. At Snap One, we’re committed to providing the best possible service and are working tirelessly to resolve this incident. Check out our status page for the most up-to-date information: https://status.snapone.com/
Posted Feb 24, 2023 - 10:25 EST
This incident affected: Partner Services Health (Website: dealer.control4.com, Website: dealer-emea.control4.com, Website: dealer.pakedge.com, Website: dealer.triadspeakers.com).