Control4 Dealer Portal is Unavailable
Incident Report for Snap One
Resolved
This incident has been resolved.
Posted Oct 25, 2022 - 16:44 EDT
Investigating
We are experiencing an issue with the Control4 Dealer Portal and investigating the issue.
Posted Oct 25, 2022 - 13:34 EDT
This incident affected: Partner Services Health (Website: dealer.control4.com, Website: dealer.pakedge.com, Website: dealer.triadspeakers.com).