Unable to checkout using a credit card
Incident Report for Snap One
Resolved
We've resolved the incident and will continue to monitor it. You can check your order status online by visiting dealer.control4.com > Account > Orders. We apologize for any inconvenience this may have caused you.
Posted Aug 18, 2023 - 09:26 EDT
Update
We are continuing to investigate this issue.
Posted Aug 17, 2023 - 11:39 EDT
Investigating
We've learned that some international partners cannot checkout using a credit card in the Control4 Dealer Portal. Our team is actively investigating the incident and will update you with more details as we have them. In the meantime, we encourage international partners to email their orders to international@snapone.com if they have difficulty checking out online.
Posted Aug 17, 2023 - 11:38 EDT
This incident affected: Partner Services Health (Website: dealer.control4.com).