Order processing delay for Charlotte, NC, and UK warehouses
Incident Report for Snap One
Resolved
We've resolved the incident and will continue to monitor. You can check your order status online. We apologize for any inconvenience this may have caused you.
Posted Feb 27, 2023 - 14:20 EST
Update
We are continuing to investigate this issue.
Posted Feb 27, 2023 - 14:20 EST
Investigating
As of 27-Feb-2023, orders are taking longer to process than usual due to a system outage impacting our Charlotte, NC, and UK warehouses. Our team is actively investigating the incident and will update you with more details as we have them.
Posted Feb 27, 2023 - 11:28 EST
This incident affected: Partner Services Health (Website: dealer.control4.com, Website: dealer-emea.control4.com, Website: dealer.pakedge.com, Website: dealer.triadspeakers.com).