Order status and balance are unavailable
Incident Report for Snap One
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 21:19 EST
Update
We are continuing to investigate this issue.
Posted Jan 25, 2023 - 13:31 EST
Investigating
We're experiencing degradation with our system that provides order status and balance information in Control4 Dealer Portal. Additionally, orders placed after 8:00 a.m. MST may experience fulfillment delays. We're working to restore the impacted system as quickly as possible. We apologize for any inconvenience this may cause.
Posted Jan 25, 2023 - 10:44 EST
This incident affected: Partner Services Health (Website: dealer.control4.com).