Product catalog unavailable on snapav.com
Incident Report for Snap One
Resolved
We have resolved the incident and will continue to monitor the situation. We apologize for any inconvenience this may have caused you.
Posted May 12, 2023 - 17:08 EDT
Monitoring
We have resolved the incident and will continue to monitor the situation. We apologize for any inconvenience this may have caused you.
Posted May 12, 2023 - 13:59 EDT
Identified
Issue identified and restoration in progress
Posted May 12, 2023 - 13:07 EDT
Investigating
Snap One Partner Portal (snapav.com) is experiencing technical difficulties that prevent partners from viewing and adding products to their carts and viewing a detailed order history. Our team is currently investigating the situation, and we will provide updates as soon as possible. Orders can be placed using the Quick Order Pad or by emailing sales@snapone.com
Posted May 12, 2023 - 13:01 EDT