Snapav.com Order Processing

Incident Report for Snap One

Resolved

This incident has been resolved.
Posted May 23, 2023 - 09:53 EDT

Monitoring

We've resolved the incident and will continue to monitor it. Please note that orders placed today, May 22, 2023, could be delayed by one business day. You can check your order status online by visiting snapav.com > My Account > Account Summary > Order History. We apologize for any inconvenience this may have caused you.
Posted May 22, 2023 - 18:52 EDT

Identified

We have found the issue and resolved part of it. Our team is still working on a complete solution. Nevertheless, you can now place orders online through snapav.com.
Posted May 22, 2023 - 16:42 EDT

Investigating

Due to a system outage, we cannot take or process orders via snapav.com and our partner support team. Additionally, we're unable to process payments for partners with payment terms. Our team is actively investigating the incident and will update you with more details as we have them. We apologize for any inconvenience this may have caused you.

Thanks,
Your Snap One Engineering team
Posted May 22, 2023 - 12:06 EDT