As of 12:25pm EDT the situation was fully resolved. We will dive deeper into root causes and provide you with details on how we will improve our services. Thank you for your patience and understanding.
Your Snap One Engineering team
Posted May 18, 2026 - 13:11 EDT
Update
Regarding the impact of this issue, emails that would have been generated between 7:10am and 12:25pm EDT will not be delivered.
Currently, systems are operating nominally and all emails generated after 12:25pm EDT should be delivered. We are monitoring closely to ensure there is no further impact before we change the status of this issue to Resolved.
Thank you for your understanding, Your Snap One Engineering team
Posted May 18, 2026 - 12:44 EDT
Monitoring
The fix has been applied and email delivery latency is returning to nominal levels. You may experience slight impacts to performance as systems fully ramp up and stabilize. More details to follow.
Thanks, Your Snap One Engineering team
Posted May 18, 2026 - 12:28 EDT
Identified
Delivery of emails from OvrC may be impacted based on an identified issue with one of our service providers. This includes device status notifications, Control4 and Luma customer hand-off invites, Control4 demo invites, MFA when using email delivery. More details will follow.
Thanks, Your Snap One Engineering team
Posted May 18, 2026 - 12:06 EDT
This incident affected: OvrC Health (Service: OvrC Notifications).